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Introduction

This document shows how to use the JNBridgePro plug-ins for Visual Studio and for Eclipse to
generate proxies and to use them in larger projects. Users can generate their proxies within Visual
Studio 2017 and 2019, and within Eclipse 3.2 through 4.10, and use the generated proxies seamlessly
in their project builds.

This document assumes that the users are familiar with the JNBridgePro standalone proxy generation
tool, and with how the generated proxies can be used. For more information on these topics, please
see the examples that ship with the INBridgePro installation, and also the Users’ Guide.

JNBridgePro plug-in for Visual Studio

The JNBridgePro plug-in for Visual Studio can be used with Visual Studio 2017, and 2019, and is
used in projects where .NET code is calling Java code. The example is taken from the “log demo”
that comes with the JNBridgePro installation. For more information on the log demo, please see the
document associated with it that comes with the installation

Installing the Visual Studio plug-in (Visual Studio 2017 or 2019)

Up through Visual Studio 2015, the Visual Studio plug-in is installed automatically when
JNBridgePro is installed in development mode. Starting with Visual Studio 2017, an additional step
must be performed. In the INBridgePro installation folder, locate the folder “VS plugin (2017 and
later).” In that folder, you will find a file JNBridgePlugin2017.vsix. Assuming Visual Studio 2017
and/or 2019 is installed, double-click on this file in Windows Explorer. The Visual Studio extension
manager will come up. When prompted, select the versions of Visual Studio in which you want the
plug-in to be installed, then follow the remaining instructions. When the process is complete, the
plug-in will be installed.

The plug-in packaged in the VSIX file will only work if INBridgePro has already been installed in
development mode on that machine, and if a valid development license has been deployed to that
machine.

Generating the proxies

Start by creating your new solution, and a C# console application. Add the files App.config and
LoggerDemo.cs (Figure 1).
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Figure 1. Log demo project

Next, create a new proxy generation project. There are several ways to do this, but the simplest way is
to right-click on the solution node in the Solution Explorer, then select Add>New Project.... In the
Add New Project dialog box that now appears, note that there is a new project type, JNBridge, and a
new template, DotNetToJavaProxies. Select that template, then name the new project and assign it a
location (Figure 2 and Figure 3).
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Figure 2. Adding a new JNBridge proxy generation project (VS 2017)
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Figure 3. Adding a new JNBridge proxy generation project (VS 2019)

Note that the Solution Explorer now contains a new proxy generation project, and a new proxy

generation document, a .jnb file. This is the same .jnb file used by the standalone proxy generator
(Figure 4).
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Figure 4. After adding the proxy generation project

Open the .jnb file by double-clicking on its node in the Solution Explorer. An editor window will

open in Visual Studio. Note that its layout resembles the GUI version of the standalone JNBridgePro
proxy generation tool (Figure 5).

4] LogDemobre - icrosot Vil Stuio

Fle Edt View Poject Buld Debug Team Took Test Amoyze INBiidgePro Window Help
BF[9D -

L3l DothetTolavaProxiesjnb + X

YH & | QuickLlaunch (Ctrl+Q) P & x

- | Debug - AnycPU < st~ | B

signin [

Solution Explorer [FEEITTTS

Figure 5. After opening the .jnb file

Next, add the files log4j.jar and logdj-core.jar to the class path to be searched for proxy generation.
(You can download the log4j JAR files from http://jakarta.apache.org/log4j/docs/index.html.) Also
add the folder in which loggerDemo\JavaClass.class is to be found. Use the menu command



http://jakarta.apache.org/log4j/docs/index.html
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JNBridgePro—Edit Classpath.... (Alternatively, you can right-click on the .jnb file node in the Solution
Explorer and select Edit Classpath... or use the Edit Classpath button in the JNBridgePro toolbar.)
The Edit Class Path dialog box will come up, and clicking on the Add... button will bring up a dialog
that will allow the user to indicate the paths of the Jar and class files (Figure 6).

Mew Classpath Element

Select a new folder arfile to add to the classpath:

Elﬂ Temp
=i DemoTests

- BooksDemo

A J_in_N_Embedding

-l J2N_LogDema

-l Java_in_WPF_Embedding
-{ml LogDemo

P i loogerDemo
ﬂ Log Demo Prodes
- N_in_J_Embedding
-l Swinglnterop

C:4Temp*Demo Tests'Log Demo®Java“logdjcare jar C:*

W

Figure 6. Adding a new classpath element

When all the necessary elements of the classpath are added, the Edit Class Path dialog should contain
information similar to that shown in Figure 7.
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ar drag file or
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i 1]

Add system CLASSPATH Cancel

Figure 7. After creating classpath

The next step is to load the classes from each of the Jar files, and to add JavaClass. For the Jar files,
use the menu command JNBridgePro—>Add Classes from JAR File... for each Jar file. For a single class
such as JavaClass, use the menu command JNBridgePro—»Add Classes from Classpath... and enter the
fully qualified class name loggerDemo.JavaClass (Figure 8). (You can also accomplish these actions
by right-clicking on the .jnb file node in the Solution Explorer, or by clicking on the appropriate
button in the JNBridgePro toolbar.)

10
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Add classes

Class name Supporting classes?

[ Doee ]

Cancel

il

Enter class name here:

Include
loggerDemo JavaClass [¢l supporting

classes
Figure 8. Adding a class from the classpath

Loading the classes may take a few minutes. Progress will be shown in the output window (in the
JNBridge sub-pane) in Visual Studio, and in the progress bar. When completed, the classes in the
log4j Jar files and loggerDemo.JavaClass will be displayed in the Environment pane on the upper left
of the editor (Figure 9). Note that INBridgePro will warn us that we are missing a number of classes
relating to JMS (Java Messaging Service), XML, and JavaMail. Since we are not going to use these
capabilities of log4j, we can safely ignore this warning.

11
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Figure 9. After adding classes

We wish to generate proxies for all these classes, so when all the classes have been loaded into the
environment, make sure that each class in the tree view has a check mark next to it. Quick ways to do
this include clicking on the check box next to each package name, or simply by selecting the menu
command JNBridgePro—Check All in Environment. Once each class has been checked, click on the
Add button to add each checked class to the list of proxies to be exposed. These will be shown in the
Exposed Proxies pane (Figure 10).

12
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Figure 10. After adding classes to Exposed Proxies pane

While one can build the proxies now, using the INBridgePro—> Build menu item, in this example, we
will wait until we have referenced the proxy generation project in the main executable’s project and
do the build as part of a build of the entire solution.

Using the proxies

Now that we have created the proxy generation project, we can reference the project from our main
project by right-clicking on the project node for our main executable and selecting Add Reference....
In the Add Reference dialog box, select the Projects tab, and select the proxy generation project.
Also, under the Browse tab, select jnbshare.dll and jnbsharedmem_x86.dll or jnbsharedmem_x64.dl1l
(or both) from the JNBridgePro installation folder, using the 4.8-targeted versions and add them to the
references (Figure 11).

Finally, add the licensing dlls jnbauth x86.dll or jnbauth x64.dll (or both) to the project. They’re not
.NET dlls, so you can’t add them as references — instead, add them to the project through
Add->Existing Item..., and make sure their Copy to Output Directory properties are both set to Copy
Always.

13
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Figure 11. After referencing the proxy generation project

Once that’s done, just build your solution. That’s all there is to it. The output of the proxy generation
project will be automatically used in your main executable’s project.

Once you’ve built the proxies, they will appear in Visual Studio’s IntelliSense when you program
against them. (If you haven’t yet built the proxy project, they won’t appear in IntelliSense until you
do.)

At this point, create, configure, and run your project as described in the “Log Demo” document.

JNBridgePro plug-in for Eclipse

The JNBridgePro plug-in for Eclipse can be used with Eclipse 3.2 through 4.13, and is used in
projects where Java code is calling .NET code. The example is taken from the “Java-to-.NET” that
comes with the JNBridgePro installation. For more information on the Java-to- NET demo, please see
the document associated with it that comes with the installation.

14
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Before using the Eclipse plug-in, make sure it has been installed. Locate the file jnbridgeproll 0 0-
eclipse.zip in the “Eclipse plug-in” folder located in the JNBridgePro 11.0 installation folder. Open
the zip file and extract its contents (a folder “com.jnbridge.plugin.eclipse 2.4.0”) to the plugins folder
inside your Eclipse installation.

If you are using the 64-bit version of Eclipse, you must use the 64-bit version of INBridgePro, and
you must add the following argument to eclipse.ini:

-vm C:/Program Files/Java/jre8/bin/javaw.exe

or use a path to some other 64-bit javaw.exe. Do not use the path to the javaw.exe that resides in
\Windows\System32.

Generating the proxies

Start by creating your main Java project. Here we will simply create a project and import the Java
files supplied in the Java-to-.NET demo (found in the file winFormDemo22.zip in the JNBridgePro
installation). Note that there are compilation errors because they reference proxy classes that do not
yet exist (Figure 13).

f% Package Explorer i3 - Q,::f}| = = B
v {3‘3 lava-to-DotMet
v [ SampleClient
v g (default package)
& MainForm.java
| MessageWindowlListener java
jnbcore_sharedmem.properties
(2] run_SwingClient.bat
= JRE Systern Library [jref]

Figure 12. The initial project
Next, we will create our proxy generation project. Select the File>New->Other... menu item. The New

dialog box will appear. Note that there are two new items under the JNBridge header: “Java to .NET
Interoperability Project,” and “Java-to-.NET Proxies” (Figure 14).
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= Plug-in Development

= PyDev

':ﬁ\' < Back Mext =

Figure 13. Creating a new interoperability project

Cancel

Select “Java to .NET Interoperability Project” and click on the Next button. Give the project a name,
and indicate its location. Do not reference any other projects.

Next, select the project node for the proxy generation. Right-click on the project node and select
New->Other.... In the New dialog box this time, select “Java to .NET proxies” and click on the Next
button. Again, select a name, but leave the location the same. The Package Explorer will now display
the new proxy generation project (Figure 15). Inside the project will be a .jnb file node. This
represents the same .jnb file that is used by the GUI-based standalone proxy generation tool.

16
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{2 Package Explorer i2 = q:ﬁ}l = = 8
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=i, IRE System Library [jref]
w ] Proxies
== bin
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Figure 14. After adding the new proxy generation project

At this point, an editor window for the .jnb file should be displayed in Eclipse (Figure 16). If it is not
displayed, you can display it by double-clicking on the .jnb file node in the Package Explorer.

© Jova - Provies/proxiesnb - Eclipse - x

[urs ]| = i)

=]

Search Project INBridgePro Run Window Help
N B O R HE-OS A E e D0

[# Package Explorer 52 5% 7 = 0 |4 proviesjnb 2
v (2 Java-to-Dothiet
~ 8 SsmpleClient

Environment Exposed Proxies Signature

¥ ¥

. Problems | @ Javadoc |[€, Declaration | & Console 22
No consoles to display at thistime.

Figure 15. The proxy generation editor in Eclipse

Next, add the assemblies SwinglInterop.dll and System.Windows.Forms.dll to the assembly list to be
searched by JNBProxy. (We will be calling methods that are not defined in SwingInterop.Form1 and
Form?2, but rather in their superclass System.Windows.Forms.Form, which is defined in
System.Windows.Forms.dll.) Use the menu command JNBridgePro—Edit Assembly List.... (Make sure
that the proxy generation editor is active.) The Edit Assembly List dialog box will come up, and
clicking on the Add... button will bring up a dialog that will allow the user to indicate the paths of

17
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SwinglInterop.dll (Figure 17). Alternatively, you can right-click on the .jnb file node in the Package
Explorer and select Edit Assembly List....

Mew Assembly List Elerment

Select a new folder or file to 3dd to the classpath:

L4

Elﬁ Temp Y
Elﬂ DemoTests
G-l BooksDemo
G-l J_in_N_Embedding
G-l J2N_LogDemo
G-l Java_in_WPF_Embedding
G-l LogDemo
G-l M_in_J_Embedding
E-fl Swinglnterop
| - dotNet
| L. SampleFoms

D S

‘.l Swinglnterop Dot Net Sic
ﬂ Java W
>

C:%Temp“Demo Tests SwingInteropdot Net SwingInten

Figure 16. Adding a new assembly list element

System.Windows.Forms.dll is in the Global Assembly Cache (GAC). Add it to the assembly list by

clicking on the Add From GAC..

. button, and selecting the System.Windows.Forms.dll from the

displayed list (Figure 18). If you have more than one version of the .NET Framework installed on
your machine, you may have more than one version of System.Windows.Forms.dll in the GAC; select

the appropriate one.

18



JNBPRO

Getting Started with JNBridgePro Plug-ins

Select azzernblies from GAC
Mame Version Culture PublicKeyToken ™
System Windows. Forms 1.0.5000.0 neutral b7 abchh1934e . .
System Windows. Forms 4000 neutral b7 ahchb1934e .
System Windows.Forms.D... 4000 neutral Jbf38h6ad364. .
System Windows.Forms.D... 4000 neutral 31bf38h6ad364. .
System Windows. Forms Vi, 4.000 neutral b7 ahchb1934e . .
System Windows. Input. Ma... 4000 neutral b7 ahchb15934e .
System Windows . Preserta... 3.5.0.0 neutral b7 7abchb1534de. .
System. Windows . Preserta... 4.0.0.0 neutral b77abchb153de. . ¥
£ >

Figure 17. Selecting an assembly from the GAC

Note that we are using the .NET 4.0 version of System.Windows.Forms.

Figure 18. Targeting .NET Framework 4.0

When all the necessary elements of the classpath are added, the Edit Assembly List dialog should
contain information similar to that shown in Figure 20.

Edit Assembly List

C\Temp'\DemoT ests\Swinglnteropidotiet\Swinglnterop.dl|
System.\Windows.Forms, Version=4.0.0.0, Culture=neutral, Put

Hid

Add ...

or drag file or
folder onto list

0

II Dg

Add from GAC... Cancel

Figure 19. After creating assembly list
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The next step is to load the classes Form1, Form2, and JavaWindowEventArgs, plus the supporting
classes. Use the menu command JNBridgePro—Add Classes from Assembly List... and enter the fully
qualified class names Swinglnterop.Form1, SwingInterop.Form?2, and
SwinglInterop.JavaWindowEventArgs, making sure that the “Include supporting classes” checkbox is
checked for each (Figure 21). Alternatively, you can also right-click on the .jnb file node in the
Package Explorer and sclect Add Classes from Assembly List....

Add classes

Class name Supporting classes?

[ Ddee ]

I

Cancel

Enter class name here:
Include

|2WINg It erop [¥] supporting

classzes

Figure 20. Adding a class from the assembly list

Loading the classes may take a few seconds. Progress will be shown in the console pane in the bottom
of the window, and in the progress bar. (If you don’t see a console, select the Window=>Show
View=>Console menu item.) When completed, Form1, Form2, and all their supporting classes will be
displayed in the Environment pane on the upper left of the proxy generation editor (Figure 22). Note
that JNBridgePro will warn us that we are missing a number of classes. Since we are not going to use
these capabilities, we can safely ignore this warning.
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Figure 21. After adding classes

We wish to generate proxies for all these classes, so when all the classes have been loaded into the
environment, make sure that each class in the tree view has a check mark next to it. Quick ways to do
this include clicking on the check box next to each package name, or simply by selecting the menu
command JNBridgePro—Check All in Environment. Once each class has been checked, click on the
Add button to add each checked class to the list of proxies to be exposed. These will be shown in the
Exposed Proxies pane (Figure 23).
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Figure 22. After adding classes to Exposed Proxies pane

Unlike the standalone proxy generation tool, we do not explicitly generate the proxies; they will be
built automatically, as needed. In this case, for example, since Build Automatically was set, the build
takes place whenever the contents of the Exposed Proxies pane changes, as it did here.

Using the proxies

To use the proxies in another project, right-click on that project’s node in the Package Explorer and
select Build Path>Configure Build Path.... Select the Libraries tab, then click on the “Add JARs...”
button. A JAR Selection dialog box will be displayed. Navigate to the associated INBridge project
node, then into its bin directory and select the proxy jar file (Figure 24).
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Figure 23. Adding a reference to the proxy jar file

One must also add the files jnbcore.jar and beel-6.10.0.jar from the JNBridgePro installation to the
Java Build Path. Then, when one performs a build, the referencing project will use the proxy jar file
generated by the JNBridge project. If the JNBridge project is out of date or has not yet been built, it
will automatically be build or rebuilt before being used.

Information concerning the generation of the proxies is displayed in Eclipse’s Console window. If the
build was unsuccessful, information describing the errors will be found there.
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